PokeUSB on Windows 7 x64

Official support and feedback forum for DITTO mini and older flash carts like PokéCard512.
kage

PokeUSB on Windows 7 x64

Post by kage » March 10th, 2010, 07:24

Can't get Windows 7 to recognize the Pokelinker. I tell it where the drivers are and it says it can't find any. Any ideas?

Lupin
Team Pokémé
Posts: 94
Joined: January 10th, 2005, 13:06

PokeUSB on Windows 7 x64

Post by Lupin » March 11th, 2010, 02:06

Another unsatisfied customer - great! ;)

Yeah, the old driver doesn't support x64. I downloaded the new libusb-win32 version and made a new driver, but i don't have any PokeUSB linkers nor have I an x64 OS. So i have no idea if this will work:

http://lupin.shizzle.it/PokeUSB_Driver.zip

Please report back if this is working.

kage

PokeUSB on Windows 7 x64

Post by kage » March 11th, 2010, 05:38

I tried it out and I got an error saying:
"Windows requires a digitally signed driver

A recently installed program tried to install an unsigned driver. This version of Windows requires all drivers to have a valid digital signature. The driver is unavailable and the program that uses this driver might not work correctly.

Uninstall the program or device that uses this driver and check the publisher's support website to get a digitally signed driver."

Then it says some stuff about the driver and where it is located on my computer. PokeUSB will simply not load after that.

Lupin
Team Pokémé
Posts: 94
Joined: January 10th, 2005, 13:06

PokeUSB on Windows 7 x64

Post by Lupin » March 13th, 2010, 01:21

That's why i stick with windows XP... please try this: http://www.raymond.cc/blog/archives/200 ... 4-bit-x64/

kage

PokeUSB on Windows 7 x64

Post by kage » March 14th, 2010, 18:24

OK. So I did that and it did install the drivers with no problems or error messages, but now PokeUSB application doesn't load when I double click on it.

Lupin
Team Pokémé
Posts: 94
Joined: January 10th, 2005, 13:06

PokeUSB on Windows 7 x64

Post by Lupin » March 15th, 2010, 01:18

errr... got no idea why that happens :-(

Did the PokeUSB app work before you installed the drivers? I don't know why it wouldn't start. Maybe it is blocked by Windows for some reason. No error message? Nothing?

If i'd have a windows 7 x64 machine I'd try it myself, but i don't. :(

kage

PokeUSB on Windows 7 x64

Post by kage » March 15th, 2010, 04:24

I restarted a couple of times and now it does seem to load. I can't really explain why because I did restart after installing the drivers.

When it does load though it says there's no device connected.

kage

PokeUSB on Windows 7 x64

Post by kage » March 19th, 2010, 03:45

Well thanks a lot for looking into it Lupin. I appreciate your help a lot (I really do!). I suppose I'll just emulate XP on my Mac to get this working.

Lupin
Team Pokémé
Posts: 94
Joined: January 10th, 2005, 13:06

PokeUSB on Windows 7 x64

Post by Lupin » March 19th, 2010, 12:35

kage, i still got this on my list of things that i want to look into. But the problem is that i don't got Windows 7 x64 on any machine close to me. I am making new carts right now - i will try to make the new linker work with win 7 x64. So maybe you will want to swap your old set with the new version once i have some sets available.

kage

PokeUSB on Windows 7 x64

Post by kage » March 19th, 2010, 21:44

I appreciate it Lupin, I just don't want you to waste your time on lil old me. If you do get around to doing more work on this I will have no problem testing anything you throw at me. Chances are good that I will want to get one of your new flashcarts when they come out. You guys do good work. ;)

Post Reply