PokeKaMini debugger bug

PM development, programming, hacking and all that fun stuff.
p0p
Team Pokémé
Posts: 84
Joined: May 9th, 2004, 20:22

PokeKaMini debugger bug

Post by p0p » June 10th, 2004, 15:50

"sub hl,1" doesnt seem to set the zero flag :/

Orion_

PokeKaMini debugger bug

Post by Orion_ » June 10th, 2004, 15:56

mmh I really had a strange thing with the debugger today, (0.5.1), here is a step by step picture: http://perso.wanadoo.fr/onori/yn/pmdebug.png
also another bug is that the debugger dont load the whole rom in memory :| I have a precalc table of 24KB in my rom, and when I try to load a value from about $14DC all the value are zero :(

PokeSlap

PokeKaMini debugger bug

Post by PokeSlap » June 12th, 2004, 00:57

$14DC is Working RAM... putting code on $1000~$1FFF will not init Working RAM, same happen at $2000~$20FF
If you really want to init RAM, put them on ROM (> $2100) and then transfer to RAM

Orion_

PokeKaMini debugger bug

Post by Orion_ » June 12th, 2004, 12:11

oops, sorry ^^
I located my code at $9a just to avoid jump to >$2100, I corrected this and now It work ^^
just waiting for mul to work, and also those strange instruction convertion with addw, maybe did you miss to increment the PC pointer of 2 ?

Orion_

PokeKaMini debugger bug

Post by Orion_ » June 12th, 2004, 18:48

yeah, finally finished my fastputpix routine without using mul ^^ (working perfectly with the debugger) I wonder how fast is it on real hardware/emulator :)

Orion_

PokeKaMini debugger bug

Post by Orion_ » June 16th, 2004, 07:41

when would be available the PM windows emulator from pu5h ?

Orion_

PokeKaMini debugger bug

Post by Orion_ » June 18th, 2004, 20:46

and another little bug :) with: addw x2,hl, it perfom a addw x2,ba, instead of hl :)

Orion_

PokeKaMini debugger bug

Post by Orion_ » June 18th, 2004, 20:48

mmhh, seems you did not test each opcodes while coding them ;)

PokeSlap

PokeKaMini debugger bug

Post by PokeSlap » June 21st, 2004, 07:12

kinda... :)
btw, im pu5h... but seems that my friends didnt liked the name, so, now im PokeSlap ^_^ Ill wait first for debugger to get better before port the Core to the PokeMini Emulator

PokeSlap

PokeKaMini debugger bug

Post by PokeSlap » June 21st, 2004, 07:13

ohh forgot... thanks for reporting bugs, try the new version ;)

Post Reply